The Things Network V2 is Permanently Shutting Down
Scheduled for Dec 1, 09:00 - 15:00 CET
Update
The list of affected components has been updated.
Posted Nov 12, 2021 - 15:25 CET
Update
We are now over a month past the September 30 deadline for migrating end devices from The Things Network V2 to The Things Stack (V3) and there are now less than 3 weeks left until the permanent shutdown of The Things Network V2 on December 1st.

In the coming weeks we will schedule brownouts of the V2 community network. The goal of these brownouts is to create temporary interruptions in applications that still rely on V2. We hope that these interruptions will then trigger alerts to the relevant people, who may not be aware that some of their applications still rely on V2. On the other hand, these interruptions will give everyone who did migrate to The Things Stack (V3) the confidence that their applications are indeed fully migrated to V3 and will continue to work correctly after the permanent shutdown of The Things Network V2 on December 1st.

Since we don't want to prevent people from migrating their applications to The Things Stack (V3), we will enable alternative access to V2 APIs so that they can keep using V2 during the brownouts.

During these brownouts, the following will happen:

- Access to the MQTT APIs will be disabled. Alternative access to the MQTT APIs will be available on ports 11883 (TCP) and 18883 (TLS).
- Access to the Storage Integration will be disabled. Alternative access to the Storage Integration will be available on port 10443 (HTTPS).
- External integrations will be paused, uplink traffic be queued and delivered after the brownout.

What will not change during these brownouts:

- Gateways will stay connected, and will keep forwarding traffic to both The Things Network V2 and to Packet Broker.
- Devices will still be able to join and receive ACKs to confirmed uplink messages.
- You can still use the Console to view your devices and schedule downlinks.
- You can still use the migration tool to migrate your devices to The Things Stack (V3).
Posted Nov 10, 2021 - 15:06 CET
Scheduled
At The Things Conference we announced that The Things Network V2 would permanently shut down in September 2021. Because of the pandemic, we later extended this date to December 2021 to give the community some more time to migrate to The Things Stack (V3).

Any updates regarding the sunset of The Things Network V2 will be posted in this maintenance announcement.
Posted Jan 25, 2021 - 14:00 CET
This scheduled maintenance affects: The Things Network v2 is Permanently Shutting Down on December 1st (V2 Cluster Discovery is Permanently Shutting Down on December 1st, V2 Console is Permanently Shutting Down on December 1st, V2 Europe has Brownouts Until Permanent Shutdown on December 1st, V2 United States - West has Brownouts Until Permanent Shutdown on December 1st, V2 Asia-Southeast has Brownouts Until Permanent Shutdown on December 1st, V2 Brazil has Brownouts Until Permanent Shutdown on December 1st, V2 Integrations have Brownouts Until Permanent Shutdown on December 1st).