Server Updates
Incident Report for The Things Network
Resolved
We're rolling out server updates to the public community network today. There may be some short service interruptions.

Update: Maintenance finished.
Posted 9 months ago. Jan 24, 2019 - 09:30 CET