The Things Indoor Gateway Unable to Connect
Incident Report for The Things Network
Resolved
After sufficient monitoring, our metrics suggest that almost all gateways have reconnected. A small portion of gateways whose configuration is managed directly by the gateway vendors require a small update for reconnection. We have reached out to these vendors and we expect this update shortly. Please reach out to us via the Forum or the community slack for persistent issues.
Posted Dec 16, 2020 - 16:06 CET
Monitoring
In order for the fix implemented yesterday (around 15:30 CET) to be effective, Gateways needed to contact the configuration server to fetch new configuration and reconnect. Some gateways immediately did that and were connected whereas others are did not. Since all gateways will by default contact the configuration server every 24 hours, we hoped that gateways gradually connected based on their individual 24 hour schedule.
However most of these gateways still did not contact the configuration server this morning. Upon further investigation, we found that the configuration server was missing a parameter that prevented gateways from receiving the configuration update. We've fixed this we see that 95% of the gateways have reconnected with the others slowly reconnecting. We will continue to monitor this until we are sure that all the gateways have reconnected.
Posted Dec 16, 2020 - 11:13 CET
Update
We have implemented a fix and we notice that about 50% of the gateways have reconnected while the rest are gradually connecting. We'll continue to monitor metrics for the reconnection of the rest of the gateways.
Posted Dec 15, 2020 - 16:08 CET
Update
We are continuing to work on a fix for this issue. We already see some improvement, as a number of gateways was able to reconnect.
Posted Dec 15, 2020 - 13:54 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 15, 2020 - 12:34 CET
Investigating
We're investigating reports that The Things Indoor Gateways are unable to connect to our cluster in Europe.
Posted Dec 15, 2020 - 11:30 CET
This incident affected: Europe (Gateway API (Basic Station)).