Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2026 - 12:00 CET
Scheduled
During this maintenance window we will upgrade The Things Stack Sandbox to The Things Stack v3.35.2.
We expect brief service interruptions during this deployment.
Here is the changelog since the current version 3.35.1:
### Changed
- Rate limiting for downlink queue operations (`DownlinkQueuePush`, `DownlinkQueueReplace`) is now applied at the application level instead of per-device. This may result in more `ResourceExhausted` (429) errors when multiple devices under the same application perform downlink queue operations concurrently.
### Fixed
- Application Server webhook registry now uses read-only Redis client for non-paginated list operations, reducing connection holding time during high traffic.
Posted Jan 21, 2026 - 10:14 CET
This scheduled maintenance affected: The Things Stack Sandbox (Europe 1 (eu1.cloud.thethings.network), North America 1 (nam1.cloud.thethings.network), Australia 1 (au1.cloud.thethings.network)).