Server Updates
Incident Report for The Things Network
Resolved
We're rolling out updates to our servers, you may experience short service interruptions.

Update: We have finished rolling out updates to our servers.
Posted 12 months ago. Oct 29, 2018 - 10:05 CET