Friday 6th April 2018

Server Updates, scheduled 1 year ago

We're doing some server updates. There may be some short service interruptions.

Update: All servers backing our routing services have been updated. This includes all UDP/MQTT APIs for gateway traffic, all gRPC/HTTP APIs for device management and all MQTT APIs for application traffic.

Update: All servers backing our Account services and Console have been updated.

Update: The NOC infrastructure has been updated.

Update: Our integrations infrastructure requires some more work, we'll keep you posted.

Update: We are redeploying a part of our integrations infrastructure on a new set of servers with higher capacity.

Update: Our integrations infrastructure is back online and catching up with the uplink queues.

Update: While our integrations are catching up with the queues, we see some of the webhooks error with 429 Too Many Requests; in such cases, the integration will retry, but this may result in out-of-order message delivery.

Update: All planned updates are done

Update: Integrations are fully caught up on all queues.